High network latency on some USA Residential ISP Proxies
Incident Report for Webshare Proxy
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 22:30 PDT
Update
We are continuing to investigate this issue.
Posted Jul 22, 2021 - 22:16 PDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2021 - 22:07 PDT
This incident affected: Proxy Server.