Connectivity issues with some of the USA proxies
Incident Report for Webshare Proxy
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 09:35 PDT
Investigating
We are currently investigating this issue.
Posted Jun 04, 2024 - 08:25 PDT
This incident affected: Proxy Server.