Elevated network latency on some of the European proxies
Incident Report for Webshare Proxy
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 15:25 PDT
Investigating
We are currently investigating this issue.
Posted Jul 21, 2021 - 15:02 PDT
This incident affected: Proxy Server.