Resolved
Resolved at 17:54 UTC. Proxy traffic, dashboard and API are operating normally.
Monitoring
Between 17:01 and 17:54 UTC on July 28, customers experienced connection failures on proxy traffic and errors accessing the dashboard and API. The cause was an internal provisioning operation that placed excessive load on our proxy allocation system, which degraded proxy authentication. Service was fully restored at 17:54 UTC, after approximately 53 minutes of impact. We are following up internally to prevent a recurrence.