Resolved
Issues resolved.
Monitoring
All systems are operational. We're actively monitoring for further issues.
Identified
We've paused updates to proxy lists while we implement a fix.
Proxies are back to normal operation.
Investigating
We're investigating degraded API and proxy performance.