The issue should now be resolved, payments should not be delayed significantly.
Resolved
Monitoring
Renewal processing is back to normal
Investigating
Some Renewals might be delayed
·