Issue has been resolved.
Resolved
Monitoring
Service are returning to normal
Investigating
Proxy List on dashboard might no load
·