Resolved
Services are returned to normal. There has been a delay in some proxy lists that will be getting back to normal now.
Monitoring
Dashboard is back to normal, any action taken during the outage will be catching up now.
Investigating
Dashboard is slow to load and can freeze.