Resolved
There was an issue where payments did not result in plan changes. This is now resolved for new payments. For users effected in this window of time we are investigating how to fix for them too.
Monitoring
Any new payments will now work as expected. We are now working to fix all effected users in the last day.
Investigating
Some user's plans are not being correctly updated after payment.