Service Congestion
Resolved
Degraded performance

Congestion is now eased. We have follow up items to investigate to prevent further incidents.

Fri, Jul 12, 2024, 04:06 PM
5 months ago
Affected components
Web Dashboard/API
Updates

Resolved

Congestion is now eased. We have follow up items to investigate to prevent further incidents.

Fri, Jul 12, 2024, 04:06 PM
10m earlier...

Identified

We are fixing this, service to resume shortly.

Fri, Jul 12, 2024, 03:55 PM