Connectivity issues with some of the USA proxies
Resolved

This incident has been resolved.

Tue, Jun 4, 2024, 04:35 PM
6 months ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Jun 4, 2024, 04:35 PM
1h earlier...

Investigating

We are currently investigating this issue.

Tue, Jun 4, 2024, 03:25 PM