High network latency on some of the USA Residential ISP Proxies
Incident Report for Webshare Proxy
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 07:19 PDT
Investigating
The proxies with some IP address are currently degraded due to underlying ISP failure. We are working on restoring the network speed for these proxies.
Posted Sep 06, 2021 - 08:00 PDT
This incident affected: Proxy Server.