Connectivity issue with some USA proxies
Incident Report for Webshare Proxy
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 10:53 PST
Identified
3% of the USA proxies are experiencing connectivity issues
Posted Feb 22, 2021 - 10:28 PST
This incident affected: Proxy Server.